// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m), \d{4}(?:-\d{2})?$").unwrap();
let string = "Percent of adults with a high school diploma only, 2000
Percent of adults completing some college or associate's degree, 2000
Percent of adults with a bachelor's degree or higher, 2000
Percent of adults with less than a high school diploma, 2014-18
Percent of adults with a high school diploma only, 2014-18
Percent of adults completing some college or associate's degree, 2014-18";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}