#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m), \d{4}(?:-\d{2})?$"
Local $sString = "Percent of adults with a high school diploma only, 2000" & @CRLF & _
"Percent of adults completing some college or associate's degree, 2000 " & @CRLF & _
"Percent of adults with a bachelor's degree or higher, 2000" & @CRLF & _
"Percent of adults with less than a high school diploma, 2014-18" & @CRLF & _
"Percent of adults with a high school diploma only, 2014-18" & @CRLF & _
"Percent of adults completing some college or associate's degree, 2014-18"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)