using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @", \d{4}(?:-\d{2})?$";
string substitution = @"";
string input = @"Percent of adults with a high school diploma only, 2000
Percent of adults completing some college or associate's degree, 2000
Percent of adults with a bachelor's degree or higher, 2000
Percent of adults with less than a high school diploma, 2014-18
Percent of adults with a high school diploma only, 2014-18
Percent of adults completing some college or associate's degree, 2014-18";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}