# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*@?(\d{2})[ -_\.]*?(\d{2})[ -_\.]*?(\d{2,4})/ $1-$2-$3/gm;t' <<< "Quando Tempo ancora 12032024
Quando Tempo ancora 12 03 2024
Quando Tempo ancora 12.03.2024
Quando Tempo ancora 12_03_2024"