#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*@?(\d{2})[ -_\.]*?(\d{2})[ -_\.]*?(\d{2,4})"
Local $sString = "Quando Tempo ancora 12032024" & @CRLF & _
"Quando Tempo ancora 12 03 2024" & @CRLF & _
"Quando Tempo ancora 12.03.2024" & @CRLF & _
"Quando Tempo ancora 12_03_2024"
Local $sSubst = " $1-$2-$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)