// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*@?(\d{2})[ -_\.]*?(\d{2})[ -_\.]*?(\d{2,4})").unwrap();
let string = "Quando Tempo ancora 12032024
Quando Tempo ancora 12 03 2024
Quando Tempo ancora 12.03.2024
Quando Tempo ancora 12_03_2024";
let substitution = " $1-$2-$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}