use strict;
my $str = 'Quando Tempo ancora 12032024
Quando Tempo ancora 12 03 2024
Quando Tempo ancora 12.03.2024
Quando Tempo ancora 12_03_2024';
my $regex = qr/\s*@?(\d{2})[ -_\.]*?(\d{2})[ -_\.]*?(\d{2,4})/mp;
my $subst = ' $1-$2-$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";