using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*@?(\d{2})[ -_\.]*?(\d{2})[ -_\.]*?(\d{2,4})";
string substitution = @" $1-$2-$3";
string input = @"Quando Tempo ancora 12032024
Quando Tempo ancora 12 03 2024
Quando Tempo ancora 12.03.2024
Quando Tempo ancora 12_03_2024";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}