import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*@?(\\d{2})[ -_\\.]*?(\\d{2})[ -_\\.]*?(\\d{2,4})";
final String string = "Quando Tempo ancora 12032024\n"
+ "Quando Tempo ancora 12 03 2024\n"
+ "Quando Tempo ancora 12.03.2024\n"
+ "Quando Tempo ancora 12_03_2024";
final String subst = " $1-$2-$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}