package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*@?(\d{2})[ -_\.]*?(\d{2})[ -_\.]*?(\d{2,4})`)
var str = `Quando Tempo ancora 12032024
Quando Tempo ancora 12 03 2024
Quando Tempo ancora 12.03.2024
Quando Tempo ancora 12_03_2024`
var substitution = " $1-$2-$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}