import Foundation
let pattern = #"\s*@?(\d{2})[ -_\.]*?(\d{2})[ -_\.]*?(\d{2,4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Quando Tempo ancora 12032024
Quando Tempo ancora 12 03 2024
Quando Tempo ancora 12.03.2024
Quando Tempo ancora 12_03_2024
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" $1-$2-$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)