# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\([A-Z]+(?!\))\b/$0)/gm;t' <<< "The dog walked (ABC in the park
The dog walked (ABC) in the park
"