using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([A-Z]+(?!\))\b";
string substitution = @"$0)";
string input = @"The dog walked (ABC in the park
The dog walked (ABC) in the park
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}