re = /\([A-Z]+(?!\))\b/m
str = 'The dog walked (ABC in the park
The dog walked (ABC) in the park
'
subst = '$0)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result