#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\([A-Z]+(?!\))\b"
Local $sString = "The dog walked (ABC in the park" & @CRLF & _
"The dog walked (ABC) in the park" & @CRLF & _
""
Local $sSubst = "$0)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)