import re
regex = re.compile(r"\([A-Z]+(?!\))\b", flags=re.MULTILINE)
test_str = ("The dog walked (ABC in the park\n"
"The dog walked (ABC) in the park\n")
subst = "$0)"
result = regex.sub(subst, test_str)
if result:
print(result)