$re = '~\([A-Z]+(?!\))\b~m';
$str = 'The dog walked (ABC in the park
The dog walked (ABC) in the park
';
$subst = "$0)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;