# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\),[^\S\n]*(?=\w)/),\n/gm;t' <<< "text cat dog cat dog
),
text rabbit cat dog
), text coffee cat dog. #need to indent this line"