import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\),[^\\S\\n]*(?=\\w)";
final String string = "text cat dog cat dog\n"
+ "),\n"
+ "text rabbit cat dog\n"
+ "), text coffee cat dog. #need to indent this line";
final String subst = "),\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}