#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\),[^\S\n]*(?=\w)"
Local $sString = "text cat dog cat dog" & @CRLF & _
")," & @CRLF & _
"text rabbit cat dog" & @CRLF & _
"), text coffee cat dog. #need to indent this line"
Local $sSubst = "),\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)