$re = '/\),[^\S\n]*(?=\w)/m';
$str = 'text cat dog cat dog
),
text rabbit cat dog
), text coffee cat dog. #need to indent this line';
$subst = "),\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;