re = /\),[^\S\n]*(?=\w)/m
str = 'text cat dog cat dog
),
text rabbit cat dog
), text coffee cat dog. #need to indent this line'
subst = '),\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result