import Foundation
let pattern = #"\),[^\S\n]*(?=\w)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
text cat dog cat dog
),
text rabbit cat dog
), text coffee cat dog. #need to indent this line
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"),\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)