use strict;
my $str = 'text cat dog cat dog
),
text rabbit cat dog
), text coffee cat dog. #need to indent this line';
my $regex = qr/\),[^\S\n]*(?=\w)/mp;
my $subst = '),\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";