using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\),[^\S\n]*(?=\w)";
string substitution = @"),\n";
string input = @"text cat dog cat dog
),
text rabbit cat dog
), text coffee cat dog. #need to indent this line";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}