# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\s\S]*?)(src=['"])\\/uploads\\/images\\/.+?(\..+?)(['"]>[\s\S]*?src=['"])\\/uploads\\/images\\/.+?\..+?(['"]>[\s\S]*?src=['"])\\/uploads\\/images\\/.+?\..+?(['"]>[\s\S]*)/$1$2some\/value\/one$3$4alue\/SomethingElse\.png$5Value3$6/gm;t' <<< "some text with <img src='/uploads/images/5d0554.jpeg'> and
<img src='/uploads/images/507a.jpeg'> or <img src='/uploads/images/0a74.jpeg'> in it."