#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([\s\S]*?)(src=['"])\/uploads\/images\/.+?(\..+?)(['"]>[\s\S]*?src=['"])\/uploads\/images\/.+?\..+?(['"]>[\s\S]*?src=['"])\/uploads\/images\/.+?\..+?(['"]>[\s\S]*)"
Local $sString = "some text with <img src='/uploads/images/5d0554.jpeg'> and " & @CRLF & _
"<img src='/uploads/images/507a.jpeg'> or <img src='/uploads/images/0a74.jpeg'> in it."
Local $sSubst = "$1$2some/value/one$3$4alue/SomethingElse\.png$5Value3$6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)