const regex = /([\s\S]*?)(src=['"])\/uploads\/images\/.+?(\..+?)(['"]>[\s\S]*?src=['"])\/uploads\/images\/.+?\..+?(['"]>[\s\S]*?src=['"])\/uploads\/images\/.+?\..+?(['"]>[\s\S]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\s\\S]*?)(src=[\'"])\\\/uploads\\\/images\\\/.+?(\\..+?)([\'"]>[\\s\\S]*?src=[\'"])\\\/uploads\\\/images\\\/.+?\\..+?([\'"]>[\\s\\S]*?src=[\'"])\\\/uploads\\\/images\\\/.+?\\..+?([\'"]>[\\s\\S]*)', 'gm')
const str = `some text with <img src='/uploads/images/5d0554.jpeg'> and
<img src='/uploads/images/507a.jpeg'> or <img src='/uploads/images/0a74.jpeg'> in it.`;
const subst = `$1$2some/value/one$3$4alue/SomethingElse\.png$5Value3$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);