import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\s\\S]*?)(src=['\"])\\/uploads\\/images\\/.+?(\\..+?)(['\"]>[\\s\\S]*?src=['\"])\\/uploads\\/images\\/.+?\\..+?(['\"]>[\\s\\S]*?src=['\"])\\/uploads\\/images\\/.+?\\..+?(['\"]>[\\s\\S]*)";
final String string = "some text with <img src='/uploads/images/5d0554.jpeg'> and \n"
+ "<img src='/uploads/images/507a.jpeg'> or <img src='/uploads/images/0a74.jpeg'> in it.";
final String subst = "$1$2some/value/one$3$4alue/SomethingElse\\.png$5Value3$6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}