re = /([\s\S]*?)(src=['"])\/uploads\/images\/.+?(\..+?)(['"]>[\s\S]*?src=['"])\/uploads\/images\/.+?\..+?(['"]>[\s\S]*?src=['"])\/uploads\/images\/.+?\..+?(['"]>[\s\S]*)/m
str = 'some text with <img src=\'/uploads/images/5d0554.jpeg\'> and
<img src=\'/uploads/images/507a.jpeg\'> or <img src=\'/uploads/images/0a74.jpeg\'> in it.'
subst = '$1$2some/value/one$3$4alue/SomethingElse\\.png$5Value3$6'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result