package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\s\S]*?)(src=['"])\/uploads\/images\/.+?(\..+?)(['"]>[\s\S]*?src=['"])\/uploads\/images\/.+?\..+?(['"]>[\s\S]*?src=['"])\/uploads\/images\/.+?\..+?(['"]>[\s\S]*)`)
var str = `some text with <img src='/uploads/images/5d0554.jpeg'> and
<img src='/uploads/images/507a.jpeg'> or <img src='/uploads/images/0a74.jpeg'> in it.`
var substitution = "$1$2some/value/one$3$4alue/SomethingElse\.png$5Value3$6"
fmt.Println(re.ReplaceAllString(str, substitution))
}