#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:="|"\s+(?:\w+="|\/>))(*SKIP)(?!)|""
Local $sString = "<record ObTime="2017-05-10T23:30" data_value="Ocean Park "The Sea WX" WA US" />" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)