const regex = /(?:="|"\s+(?:\w+="|\/>))(*SKIP)(?!)|"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:="|"\\s+(?:\\w+="|\\\/>))(*SKIP)(?!)|"', 'g')
const str = `<record ObTime="2017-05-10T23:30" data_value="Ocean Park "The Sea WX" WA US" />
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);