using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:=""|""\s+(?:\w+=""|\/>))(*SKIP)(?!)|""";
string substitution = @"";
string input = @"<record ObTime=""2017-05-10T23:30"" data_value=""Ocean Park ""The Sea WX"" WA US"" />
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}