use strict;
my $str = '<record ObTime="2017-05-10T23:30" data_value="Ocean Park "The Sea WX" WA US" />
';
my $regex = qr/(?:="|"\s+(?:\w+="|\/>))(*SKIP)(?!)|"/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";