$re = '/(?:="|"\s+(?:\w+="|\/>))(*SKIP)(?!)|"/';
$str = '<record ObTime="2017-05-10T23:30" data_value="Ocean Park "The Sea WX" WA US" />
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;