import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:=\"|\"\\s+(?:\\w+=\"|\\/>))(*SKIP)(?!)|\"";
final String string = "<record ObTime=\"2017-05-10T23:30\" data_value=\"Ocean Park \"The Sea WX\" WA US\" />\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}