const regex = new RegExp('(n\\\\'t|\\\\'m|\\\\'ll|\\\\'ve|\\\\'s|\\\\'re|\\\\'d)', 'gm')
const str = `should've can't mustn't we'll`;
const subst = ` \1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);