import Foundation
let pattern = #"(n\'t|\'m|\'ll|\'ve|\'s|\'re|\'d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"should've can't mustn't we'll"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" \1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)