$re = '/(n\'t|\'m|\'ll|\'ve|\'s|\'re|\'d)/m';
$str = 'should\'ve can\'t mustn\'t we\'ll';
$subst = " \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;