use strict;
my $str = 'should\'ve can\'t mustn\'t we\'ll';
my $regex = qr/(n\'t|\'m|\'ll|\'ve|\'s|\'re|\'d)/mp;
my $subst = ' \\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";