# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\-\s\w+)\n(\-\s\w+)\n(\-\s\w+)/$1\n\n$2\n\n$3/;t' <<< "- group1
- group2
- group3"