using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\-\s\w+)\n(\-\s\w+)\n(\-\s\w+)";
string substitution = @"$1\n\n$2\n\n$3";
string input = @"- group1
- group2
- group3";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}