// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\-\s\w+)\n(\-\s\w+)\n(\-\s\w+)").unwrap();
let string = "- group1
- group2
- group3";
let substitution = "$1\\n\\n$2\\n\\n$3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}