#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\-\s\w+)\n(\-\s\w+)\n(\-\s\w+)"
Local $sString = "- group1" & @CRLF & _
"- group2" & @CRLF & _
"- group3"
Local $sSubst = "$1\n\n$2\n\n$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)