$re = '/(\-\s\w+)\n(\-\s\w+)\n(\-\s\w+)/';
$str = '- group1
- group2
- group3';
$subst = "$1\n\n$2\n\n$3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;