import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\-\\s\\w+)\\n(\\-\\s\\w+)\\n(\\-\\s\\w+)";
final String string = "- group1\n"
+ "- group2\n"
+ "- group3";
final String subst = "$1\\n\\n$2\\n\\n$3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}