const regex = /(\-\s\w+)\n(\-\s\w+)\n(\-\s\w+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\-\\s\\w+)\\n(\\-\\s\\w+)\\n(\\-\\s\\w+)', '')
const str = `- group1
- group2
- group3`;
const subst = `$1\n\n$2\n\n$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);