re = /(\-\s\w+)\n(\-\s\w+)\n(\-\s\w+)/
str = '- group1
- group2
- group3'
subst = '$1\\n\\n$2\\n\\n$3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result