# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\-\s\w+)\n(\-\s\w+)\n(\-\s\w+)"
test_str = ("- group1\n"
"- group2\n"
"- group3")
subst = "$1\\n\\n$2\\n\\n$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.